Rear Hatch Lock

BCXterra Nov 28, 2019

  1. BCXterra

    BCXterra Bought an X

    Messages:
    101
    Having a bit of issue with my rear hatch lock.

    Key fob will unlock all other doors, but only partially releases rear hatch. I pull the handle and it opens about 1/4”, if at all.
    If I shut it again and unlock with the key it works fine.
    Has anyone else had this happen. Any ideas before I tear into it and try to figure out?
     
  2. KC!

    KC! Bought an X

    Messages:
    156
    It sounds like a connection issue to the actuator, almost as if it’s not receiving the necessary power to fully release the latch.
     
  3. Ocala X

    Ocala X Test Drive

    Messages:
    37
    Location:
    Middleburg, FL
    Yeah, mine does that too...it has for years. It just doesn't bother me enough to do something about it. Please let me know what you find out...I'm curious if it's an easy fix or not. I've always lean towards the side of it possibly being gummed up.
     
  4. harryron

    harryron The Grumpiest of Mid-Westerners Supporting Member

    Messages:
    7,742
    Location:
    ohio
    Mine did that I sprayed it with penetrating oil then greased it, has been working flawlessly every since.
     
    SC_AJ and BCXterra like this.
  5. Bklyn.X

    Bklyn.X Sliders Supporting Member Founding Member

    Messages:
    849
    Location:
    Brooklyn, NY
    Yes ^
    I cleaned mine with electric parts cleaner then sprayed it. Fixed.
     
    BCXterra likes this.
  6. BCXterra

    BCXterra Bought an X

    Messages:
    101
    Update- didn’t do anything and it’s working again!
     
  7. Bklyn.X

    Bklyn.X Sliders Supporting Member Founding Member

    Messages:
    849
    Location:
    Brooklyn, NY
    Mine did that as well and then started failing at a time I needed it to open on the trail. I'd clean and spray it when I had the time and it's working if I was you....
     
  8. BCXterra

    BCXterra Bought an X

    Messages:
    101
    Yes, still planning on opening it up, just waiting for a bit warmer weather to open it up.
     
  9. CHUG

    CHUG First Fill-Up (of many) Supporting Member

    Messages:
    252
    Location:
    McMinnville, Orygun
    had same issue.. Can open with Fob. But key inserted, will not rotate. stuck. Figured gummed up with Dust & goo..
    I systematically, would put key in jiggle it.. Repeat that few times during a month.. works again.. just need lube.

    Thar is a trick(SEE NOTE) to drill a 1" hole 7" over 4" up.. and it will allow one to poke finger for Rear exit. When you sleep in the back.

    ****NOTE: Idea was invent by a fellow ( surf & Snow) over in the Other failed Xterra site.. Measurements are just a guess.
     
    BCXterra likes this.
  10. westslope

    westslope Bought an X

    Messages:
    162
    Location:
    Wildfire country, BC
    You mean 3C (37F) is not warm enough? :D

    In the meantime, you could always liberally spray the rear latch with WD-40 fish-based oil and see if that helps. It will be easy to wipe off if it does not help.
     
    BCXterra likes this.

Share This Page