Funky noises in the dash.

Smeegle

Test Drive
Location
Minnesota
Hello everyone, maybe another member has had this issue? ... From under the middle center of the dash I get some odd "flippy floppy" noises that I may be able to best describe as what sounds like a small dying (flopping) rodent in an empty shoe box. I'm going to take a guess that this may be coming from my climate control system..? I will confirm that there are no dying rodents, nor empty shoe boxes in the X. This happens randomly after either first starting the vehicle or within a minute or so after shutting it off. It goes on for 20 - 30 seconds. Thoughts..?
 

outback97

Wheeling
Supporting Member
Location
SLC, Utah
If it is a rodent, it should die soon and the noise will stop, but it will start to smell pretty bad.

If it's not a rodent in a shoe box, it's probably either the mode door actuator or blend door actuator.

The mode door is above the gas pedal and relatively easier to service, while the blend door is buried in the dash near the passenger side and apparently a PITA to get to.

I've got some info on replacing the mode door actuator if it's that. Next time you notice it poke your head up into the driver's footwell and see if it's coming from something that looks like this.

Not sure if the video embed will work, but this was taken by Brett, the original owner of my 2009 and it shows the clickety clackety mode door actuator.

ABLVV86DplAn9qtJlAb8-QrHtAJ-_GWgsav1N6b3LPTBvI2zi-0yhiWawLfwtcWWPshDll6OlyyAHkax0IQE0b1LAzaPXFY-1QVZY8NnRPlJfGOxny0FX3Gb=w2400


It's not normal behavior. Mine was clicking when I bought the truck used, and the seller mentioned that it had been doing that for a while. It was more annoying than problematic, but it did get more pronounced as time went on. Not sure if it would have eventually failed; I was annoyed enough by it that I replaced it before that happened.
 
Last edited:

ElGuevara

Bought an X
Supporting Member
Location
Chiriaco Summit
I have the same kind of noise and it seems to come from behind the HU, so it might be the blkend door
If it is a rodent, it should die soon and the noise will stop, but it will start to smell pretty bad.

If it's not a rodent in a shoe box, it's probably either the mode door motor (easier to get to but still kind of a pain to work on) or blend door motor (quite a bit harder to get to as I understand it).

The mode door is above the gas pedal, and the blend door is buried in the dash near the passenger side. I've got some info on replacing the mode door motor if it's that.
:confused:
 

CHUG

Lockers Installed
Supporting Member
Its the blend door..
turn Key to on, that everything lights up.. heater, fans, etc. But not Full Start. Try a Lowe floor board setting on control knobby..
or other position.

Turn key off.
wait about 1.5 minutes or so.. The Blend door will go into Dying rodent mode to self seat.. Stupid engineer.. needs a beating for creating that step.

Been awhile, someone added a Zip tie to prevent it from doing that.. Mine does it and its annoying.. when shutting off engine, and Messing with a ham radio or Phone.. hearing that go off...

Its a pain...
 

Smeegle

Test Drive
Location
Minnesota
Thanks for the info! (So far) everything appears to be working ok. The noise and its randomness was what caught me off guard the first few times it happened.
 
Top