2004 Xterra Will Not Communicate With Ca Smog Machine.......?

rshimizu12 Feb 14, 2020

  1. rshimizu12

    rshimizu12 Test Drive

    Messages:
    10
    Went to have a smog test done today and the smog place told me that that their smog machine cannot communicate with my 2004 Nissan Xterra XE 2.4L 4 cyl.....? Now the really odd thing is that the OBD2 scanners are able to analyze see and and diagnose the OBD2 system......? There is no codes showing and the system is normal....!! This really bizarre and aggravating grrr....!!!
     
  2. TheCrabby1

    TheCrabby1 Bumpers Installed Supporting Member

    Messages:
    1,164
    Location:
    Burtonsville, Md
    Since your scanner/analyzer isn't showing anything have you thought about driving to another test facility ? I have 3 within 1/2 hour of my house but that's this crazy a$$ / greedy state of Md I live in !!
     
  3. rshimizu12

    rshimizu12 Test Drive

    Messages:
    10
    Already went to several smog places with the same result. My only theory is that the ground is bad and the voltage or resistance is out of spec. Thus causing a communication error.
     
    TheCrabby1 likes this.
  4. rshimizu12

    rshimizu12 Test Drive

    Messages:
    10
    I went back to smog place and the technician told me that he was able to check for codes. But the problem was that the smog machine was unable to transfer data. I went through and checked all the ground and performed voltage tests as well. So this leads me to believe that something is wrong with the ECU. I ordered another used ECU.

     

Share This Page