Deadpilot's Conversion from 2wd to 4x4 SAS

Deadpilot Nov 15, 2011

  1. Deadpilot

    Deadpilot <img src="http://i164.photobucket.com/albums/u7/ra Founding Member

    Messages:
    717
    Location:
    Fallbrook, CA
    She is alive!!! Drive train wobble gone for the most part. Very little is there. Brakes are good. Speedo is working not sure how off it is yet. I put a new battery in a blue top in with 900 CCA.
    Tomorrow the X goes in for a trans fluid flush and then Tues it will get its alignment.
     
  2. caseycamby

    caseycamby Suspension Lift

    Messages:
    4,278
    Location:
    Marion, NC
  3. drbandkgb

    drbandkgb Titan Swapped / SAS'd Founding Member

    Messages:
    10,856
    Whoobooooo
     
  4. Deadpilot

    Deadpilot <img src="http://i164.photobucket.com/albums/u7/ra Founding Member

    Messages:
    717
    Location:
    Fallbrook, CA
    So major set back. Got the X to the shop barely. I have a bad steering issue. It pulled right then I turned right then it over corrected it self. So I had a buddy who builds off trucks look at it. And he said that he could tell the angle of the caster was off. I told him I had it set at 7° and the inner c needed to 7° the other way. So that's next to fix
     
  5. Deadpilot

    Deadpilot <img src="http://i164.photobucket.com/albums/u7/ra Founding Member

    Messages:
    717
    Location:
    Fallbrook, CA
    So I got the toe problem fixed to drive it home just to take it apart again. But at least I'll have a measurement that's good to go back too. Steering still a mess but that's cause the caster angle I'm guessing. But I think I'm gonna have to put in a sway bar on front with disconnects links. I just have way too much body roll for the street.
     
  6. CaptainMorgan_SOS

    CaptainMorgan_SOS Need Bigger Tires

    Messages:
    680
    Location:
    Alamogordo, NM
    Meh, you'll get used to it ;)
     
  7. Deadpilot

    Deadpilot <img src="http://i164.photobucket.com/albums/u7/ra Founding Member

    Messages:
    717
    Location:
    Fallbrook, CA
    True lol.
     
  8. schmidt1894

    schmidt1894 Test Drive

    Messages:
    36
    Location:
    Corpus Christi Texas
    Jesus. I just looked at this thread and read through it from page one... all i can say... i tip my hat off to you. WOW. Nicely done.
     
  9. Deadpilot

    Deadpilot <img src="http://i164.photobucket.com/albums/u7/ra Founding Member

    Messages:
    717
    Location:
    Fallbrook, CA
    So there other day I went to move my X and I can't get the shifter to move into gear unless I use that shift lock tab thing. Doesn't unlock with the brakes pressed like it should. Also now my horn doesn't work when I hit it but it goes off when I locked the X. I have no idea what is going on now.
     
  10. drbandkgb

    drbandkgb Titan Swapped / SAS'd Founding Member

    Messages:
    10,856
    Dang it man.. one step forward.. two back
     
  11. Deadpilot

    Deadpilot <img src="http://i164.photobucket.com/albums/u7/ra Founding Member

    Messages:
    717
    Location:
    Fallbrook, CA
    Yup. But that's the joys of custom builds. But I still have to figure the problem lol.
     
  12. Deadpilot

    Deadpilot <img src="http://i164.photobucket.com/albums/u7/ra Founding Member

    Messages:
    717
    Location:
    Fallbrook, CA
    OK so after a little break from the project to do some other things. I have figured out some solutions to the problems I'm having with my X. So after this storm system moves out I will bring the welder back out on and add a few supports on some weak spots and level the steering bar to get rid of the bump steer and then take her for another test drive.

    Sent from my SM-N915V using Tapatalk
     
  13. Timrich

    Timrich Super Duper Moderator Founding Member

    Messages:
    2,398
    Location:
    Central FL
    Sometimes taking a break helps you figure out the problem.

    Sent from my SM-G925P using Tapatalk
     
  14. Deadpilot

    Deadpilot <img src="http://i164.photobucket.com/albums/u7/ra Founding Member

    Messages:
    717
    Location:
    Fallbrook, CA
    Very true it is. And also consulting people also helps.

    Sent from my SM-N915V using Tapatalk
     
  15. Deadpilot

    Deadpilot <img src="http://i164.photobucket.com/albums/u7/ra Founding Member

    Messages:
    717
    Location:
    Fallbrook, CA
    So quick update since it's been awhile. I have figured out why a bad wondering in the front. My panhard bar and steering link were parallel to each other which was correct. But the issue I forgot about was they should have close as possible to parallel to axle/ground. So that will get fixed next week once I get the steel in the make the fixes.
    Then my drive train vibration was caused by the trans bolts being stripped out. I guess the factory bolt holes in trans don't like the added weight of the divorce transfer case. Yes that is on its own mount but it all kinda flows together with the weight.

    So maybe next week she'll be driving down the road again.


    Sent from my SM-N915V using Tapatalk
     
  16. GPD605X

    GPD605X Lockers Installed Founding Member

    Messages:
    1,595
    Location:
    Gulfport, MS
    Nice! Can't wait to see it all up and running
     
  17. Deadpilot

    Deadpilot <img src="http://i164.photobucket.com/albums/u7/ra Founding Member

    Messages:
    717
    Location:
    Fallbrook, CA
    So been working on the front the last few days. And I was able to get panhard bar semi parallel to axle and the steering link parallel to panhard bar. So everything should be good with the bump steer issue and the axle wondering issue. Tomorrow is trans mount modification.

    Pics from lunch stopping. I'll post better ones up tomorrow.
    [​IMG]

    [​IMG]

    Sent from my SM-N915V using Tapatalk
     

Share This Page