2007 Xterra - Parking Lights Won't Turn Off !!

sgsy2k66 Aug 11, 2019

  1. sgsy2k66

    sgsy2k66 Test Drive

    Messages:
    8
    Just purchased 2007 Xterra S 4L with the factory trailer light harness, and the parking lights will not turn OFF (key removed, door locked/unlocked). NOT the brake lights. Rear tail lights left and right, front yellow corner lights left and right, and yellow turn signal running light (low beam) left and right. Have removed 2 fuses (Illumination and Tail Lights) to get lights off, as not to run battery down. Turn signals and flashers work fine front and rear, even after removing fuses. Battery has been replaced, as it has been sitting dead for a long time. Have remove aftermarket alarm as I thought that might be the problem. No Engine or ABS codes. Truck runs fine but need to fix this issue before I take it on a long trip. As far as I can tell there is no specific relay for front and rear running/parking lights to stay ON. I can not figure out how a short or relay can cause 2 different circuits to stay ON??? I suspect the BCM or IPDM, but would like some outside input before I even think of replacing expensive parts... as I am cheap. upload_2019-8-11_15-47-48.gif
    Thanks
     
  2. Just a Hunter

    Just a Hunter Test Drive

    Messages:
    27
    Location:
    Georgia
    This is not an uncommon problem based on what I'm seeing on the net.

    However, the fix is not so clear.

    Fuses, relays and ipdms are claimed to be at fault
     
  3. 29erClan

    29erClan Test Drive Supporting Member

    Messages:
    28
    Sounds like the ignition relay seized up and the IPDM is trying to warn you.
    20190812_071529.jpg

    I'd also suspect an old white IPDM needing to be replaced with the updated black version.
     
    sgsy2k66 and jsexton like this.
  4. Zack.

    Zack. Test Drive Supporting Member

    Messages:
    25
    Location:
    Livermore, CA
    Certain lights stay on when you replace with an led without a resistor, don’t recall exactly which ones they are but may be worth checking if PO had replaced them.
     
    sgsy2k66 likes this.
  5. josx2

    josx2 Bought an X Supporting Member

    Messages:
    180
    Location:
    Mebane, NC
    first thing I'd do is disconnect the trailer harness from under the bumper & pull the two respective relays out (located under pass. side kick panel). Get that variable out of the equation. If the lights remain on.....we can go from there.
     
    sgsy2k66 likes this.
  6. sgsy2k66

    sgsy2k66 Test Drive

    Messages:
    8
    This what I leaning towards as an answer. Any ideas as to a source on ignition relay only, and IPDM only, other than dealer? And yes, i do have the older white board.
     
  7. josx2

    josx2 Bought an X Supporting Member

    Messages:
    180
    Location:
    Mebane, NC
    sgsy2k66 likes this.
  8. sgsy2k66

    sgsy2k66 Test Drive

    Messages:
    8
    I removed the 2 relays on passenger side kick panel (any idea what the 3rd empty relay socket is for?). Disconnected trailer harness from under truck behind rear wheel well. Same light are still on.
     
    josx2 likes this.
  9. sgsy2k66

    sgsy2k66 Test Drive

    Messages:
    8
  10. 29erClan

    29erClan Test Drive Supporting Member

    Messages:
    28
    The IPDM is plug and play, each connector only fits in 1 place, and no programming is required. (BCM and ECM would need to be programmed for the anti-theft crap to let your keys work.) Just be sure to disconnect the battery first to prevent any accidental shorts.

    Here's a used one out of a titan for $93:
    https://www.ebay.com/itm/10-Titan-A...Body-Module-Fuse-Box-284B7-ZE03C/183915267663
    I got really lucky last December and got a C model for $27 and put it in a pathfinder. It's been fine since. The B model black one should also work fine and is still better than the white version.
     
    sgsy2k66 likes this.
  11. sgsy2k66

    sgsy2k66 Test Drive

    Messages:
    8
    I think that 284B7-ZE03C is for years 2010+, and what I need is 284B6-ZE03C years 2005-2010 (2007 Xterra). Please correct me if I am wrong.
     
  12. 29erClan

    29erClan Test Drive Supporting Member

    Messages:
    28
    I could be remembering wrong, but 284B6 refers to the board part itself and 284B7 refers to the board snapped into the plastic shell assembly all together.

    Also not sure if I would trust "bricad15". I just went out and took a picture of my IPDM and it has the last digit of the model scratched off and blacked out. I mean, why else would you do that unless you're shipping out the cheaper older B model and selling it in the box of the newer C model? At least when you buy from him you get the new cover to go with it. And even if I got cheated and paid for a new model and got the older one, it has worked fine since June last year.
    My new IPDM order.jpg
    My new IPDM actual part number.jpg
     
    sgsy2k66 likes this.
  13. sgsy2k66

    sgsy2k66 Test Drive

    Messages:
    8
    What year is your X ?
     
  14. 29erClan

    29erClan Test Drive Supporting Member

    Messages:
    28
    I have a 2009 and have put a ZE03C into a 2006 pathfinder with no trouble. I bought a ZE03C but may have received a ZE03B for all I can tell. (@josx2, I'm curious if you would please get a picture of yours, has your model number been altered too?)

    Also seen a ZE03B in a relative's 2010 pathfinder I work on that appears to be the original.
     
    sgsy2k66 likes this.
  15. jsexton

    jsexton Bought an X Supporting Member

    Messages:
    169
    Location:
    Lewis Center, OH
    3rd socket is for another relay that’s needed if you have a manual transmission. Automatic transmission only needs 2 relays.
     
    sgsy2k66 likes this.
  16. josx2

    josx2 Bought an X Supporting Member

    Messages:
    180
    Location:
    Mebane, NC
    plug-n-play. Pull old one out...put new one in.

    Bricad15 IS Brian who was at Cherry Hill Nissan (aka JerseyParts on TNX). that seller IS trustworthy....that's who I bought mine from. I had messaged Brian over on TNX first...then found the IPDM on ebay after I didn't hear from him for a couple of days. After I bought it, he got back to me on TNX and asked if I was the one that just bought the one on ebay.
     
    sgsy2k66 likes this.
  17. 29erClan

    29erClan Test Drive Supporting Member

    Messages:
    28
    I would have 100% agreed with you until I saw the model number on the one I bought from him had been altered. Please, see the photo I posted above and compare to yours. You don't even have to unplug anything, just slide it out and look on the back.
     
  18. josx2

    josx2 Bought an X Supporting Member

    Messages:
    180
    Location:
    Mebane, NC
    dude...I messaged with him on TNX about my ebay purchase. it's the same guy LOL

    if anything, shoot him a message via ebay to find out whta's up w/ that that. I can't speak for him about what's up with that. My only guess is that the C vs B doesn't matter one bit. He's worked close w/ the X community...he's not gonna screw anyone over.

    can't look at mine...don't have the truck w/ me at work right now. maybe i'll remember to look later this evening.
     
  19. 29erClan

    29erClan Test Drive Supporting Member

    Messages:
    28
    Hey, I scratch off the model or serial numbers on everything I sell on ebay. Nothing fishy about that. Doesn't everybody?o_O
     
  20. sgsy2k66

    sgsy2k66 Test Drive

    Messages:
    8
    Look like the consensus is the IPDM is the likely culprit. On Ebay and other sites I am getting conflicting part numbers for the 2007 Xterra 4WD. These are the newer (Black) replacement IPDM part numbers that I have come across:

    248B6-ZE03C
    and
    248B7-ZE03C

    From photos, I see they are different. I just want to make sure I get one that works for my 2007. Thank you all for your input.
     
  21. jsexton

    jsexton Bought an X Supporting Member

    Messages:
    169
    Location:
    Lewis Center, OH
    Hmm. That almost sounds like he found the oem manufacturer selling them aftermarket. It’s pretty common to see part numbers scratched off in that scenario. Still shouldn’t be selling it as oem Nissan if that was the case though.
     
  22. sgsy2k66

    sgsy2k66 Test Drive

    Messages:
    8
    FYI... Purchased used from eBay Part Number 284B7-ZE03C (Thanks 29erClan, for then link!) and after 2 days the parking lights are NOT coming by themself. The electric radiator fan now goes on when needed, as it was getting too hot at times. So I am declaring it a success! This is the updated IPDM (black) and the original cover fits over it just fine, though the info on it is for the old IPDM. Also note that the Xterra would not start until I populated fuses F-21, F23, F24. I found several online that these fuses were not install as well. Again, Thanks to All.

    IMG_20190816_120457783.jpg IMG_20190816_120529613 (1).jpg
     
    29erClan and jsexton like this.

Share This Page