2004 first gen XE

jd black

Test Drive
If anybody could I would like to get photos of a perfectly working 2004 engine against the firewall everything just so I can see what I'm missing I bought mine used and I'm trying to figure out what I need to replace and what I need to do there's a few things that look like they're missing but I'm not sure what they are. I've got all the factory service manuals and they are not 100% helpful
 

kirk

Butterfly King
Moderator
Supporting Member
Location
Allen, Texas
I can probably take pics if no one has any handy. Can you tell us what you are working on or whats wrong?
 

Muadeeb

Nissan al Gaib
Admin
Location
Dallas
Just a note: You mentioned in another post that you have the 4 cyl KA24. That engine wasn't too common, as most had the 6 cyl VG33.
 

jd black

Test Drive
I can probably take pics if no one has any handy. Can you tell us what you are working on or whats wrong?
Pretty much I'm just replacing lines and stuff like this but there's a few things like I think it's the heater hose but I'm not sure if that's what it is is missing it's coming out of the the left side of the firewall which would be the passenger side really but there's two hose couplers coming out but I don't know what goes in it you know what I mean so I'm just trying to figure things out and the factory service manuals aren't the greatest in the world
 

jd black

Test Drive
Yeah these are the two ports that I was talking about looks like whatever was on there one of them rotted off and it looks like the whole damn hose the metal pipe that came out of there is almost rotted out so I may have to get in there and redo that
 

Attachments

  • 17192822568255800300494999919520.jpg
    17192822568255800300494999919520.jpg
    2.3 MB · Views: 3

Prime

Shut up Baby, I know it!
Admin
Location
Denver Adjacent
Yeah these are the two ports that I was talking about looks like whatever was on there one of them rotted off and it looks like the whole damn hose the metal pipe that came out of there is almost rotted out so I may have to get in there and redo that
Looks like you don't have heat at the moment.
 

relentless044

Silver Slut
Supporting Member
Yeah these are the two ports that I was talking about looks like whatever was on there one of them rotted off and it looks like the whole damn hose the metal pipe that came out of there is almost rotted out so I may have to get in there and redo that
heater core, and someone decided living in florida it wasn't worth tearing the entire dash apart and dealing with the air bags to replace, can't say I blame him
 

relentless044

Silver Slut
Supporting Member
That’s exactly what those 2 ports are for, is the heater core. Replacing it is a bit of a chore like I mentioned
 

jd black

Test Drive
Yeah I'm starting to realize that pretty much all the work that I'm going to have to do to this this old girl is going to be a lot of work. My exhaust relay hose went out the other day cuz the guy that previously owned it he tightened the the screw clamp too tight and shredded the end of the hose and didn't have any extra hose passed it so it chewed the engine so it just blew. And it just so happens it had to be in the back of the engine. For my first repair. Lol
 
Top